MIDI not received from Arturia Keylab Essential 61

Need help with iMIDIPatchbay? Ask here!
Posts: 1
Joined: Sun Apr 12, 2020 5:59 pm

MIDI not received from Arturia Keylab Essential 61

Post by kstrx »

For live performance, I am using iMIDIPatchBay with two masters, a Yamaha MX88 and an Arturia Keylab Essential 61, through an iConnectMIDI4+ interface to my iPad. I use the MX88 to play programs where I want a piano action, and I use the Arturia as a controller to play a different program on the MX88 on a different channel, where a synth/organ action is wanted. For example, the MX88 might be set to a grand piano on one channel, with the Arturia set to play one of the MX88's organ sounds on another channel.

This was all working at one time, but it is no longer working.

Everything with Master 1 (the MX88) works fine. In iMIDIPatchbay, the device is set to iConnectMIDI4+ DIN1; the channel is set 1. Splits and layers work fine, by setting Extern1 and 2 to the same device but different channels (2 and 3). When I play the MX88, the MIDI 1 light on the interface lights up, and the Receiving MIDI light in iMIDIPatchBay flashes red. Program changes for each song work as expected. So far, so good.

The Arturia is Master 2. It's connected to Host 1 (USB) on the interface. In iMIDIPatchbay, Master 2's device is set to iConnectMIDI4+ HST 1, channel 4. When I play the Arturia, the Host 1 light on the interface lights up, but the Receiving MIDI light in iMIDIPatchbay does not flash, and no sound plays on the MX88.

Of course, Master 2 is turned on in every song, I've tried swapping cables, and I've tried using the Arturia's DIN jack instead of USB (connecting to DIN2 on the interface and selecting iConnectMIDI4+ DIN2 for the master device in iMIDIPatchbay). None of those actions helped. The Arturia works fine plugging directly into my iMac for use with Logic Pro X, so I know it works.

This all seemed to work "out of the box" at one time, and worked for several live gigs. I don't think I even had to do anything with iConfig (to route ports, remap MIDI channels, etc.). I tried some different things in iConfig, but nothing solves the problem.

Any assistance is appreciated. Thank you.