MF Splitter: I keep hearing both sounds across the whole keyboard although I've setup a split Topic is solved

Need help with Midiflow for Audiobus? Ask here!
Post Reply
Any User
Posts: 3
Joined: Tue Mar 26, 2019 6:15 pm

MF Splitter: I keep hearing both sounds across the whole keyboard although I've setup a split

Post by Any User » Wed Mar 27, 2019 1:26 pm

Hi!
I've set up Audiobus with two MIDI lanes, both with my MIDI keyboard (connected via iRIG MIDI 2) as source and Animoog and FM4 as destinations. Both lanes have MF Splitter as effect.

I would expect to hear Animoog in the lower half, and FM4 in the upper half of the keyboard. However, I hear both of them across the whole keyboard.

Here is my preset: http://preset.audiob.us/yJKMzcobqQxJxN0
Attachments
IMG_3880B33B2148-1.jpeg
IMG_3880B33B2148-1.jpeg (92.35 KiB) Viewed 116 times
IMG_0B973DCE5E37-1.jpeg
IMG_0B973DCE5E37-1.jpeg (94.73 KiB) Viewed 116 times

User avatar
Johannes
Site Admin
Posts: 59
Joined: Mon Mar 25, 2019 3:06 pm

Re: MF Splitter: I keep hearing both sounds across the whole keyboard although I've setup a splitAccepted answer

Post by Johannes » Wed Mar 27, 2019 1:32 pm

Hi!
I think your synth apps receive the MIDI data from your keyboard directly and not exclusively from Audiobus, which is actually an issue of the synth app. Because of that, all MIDI stuff that you set up in Audiobus (and included MIDI effect apps like MF Splitter) is then bypassed. To fix that, you can go to the MIDI settings of the synth app and try to find a setting where you can manually disable reception on those other MIDI ports. I've attached a screenshot how that works with FM4. Note that only Audiobus 3 has a checkmark.

I hope that helps!
Attachments
IMG_31379AFB779E-1.jpeg
IMG_31379AFB779E-1.jpeg (127.16 KiB) Viewed 114 times

Post Reply