Routing with limited key range still plays outside notes Topic is solved

Need help with Midiflow? Ask here!
Post Reply
Any User
Posts: 3
Joined: Tue Mar 26, 2019 6:15 pm

Routing with limited key range still plays outside notes

Post by Any User » Wed Mar 27, 2019 12:57 pm

Hi!
I have a simple setup, just one routing in which I limit the key range from C1 to C2. The input comes from my master keyboard, and the destination is iGrand Piano. For some reason, the key range seems not to have an effect, the sound plays across the whole keyboard. I've attached the Midiflow preset and the MIDI settings of iGrand Piano.
Attachments
IMG_25C1A88B7B1A-1.jpeg
IMG_25C1A88B7B1A-1.jpeg (158.14 KiB) Viewed 189 times
preset-1.mflw
(2.53 KiB) Downloaded 30 times

User avatar
Johannes
Site Admin
Posts: 100
Joined: Mon Mar 25, 2019 3:06 pm

Re: Routing with limited key range still plays outside notesAccepted answer

Post by Johannes » Wed Mar 27, 2019 1:10 pm

Hi,
I think you ran into a common problem: iGrandPiano is receiving the MIDI data of your keyboard directly. You could probably quit Midiflow and still hear the sound, because it is bypassed. To solve the issue, you have to make sure that iGrandPiano does not receive anything from the keyboard directly, but only from Midiflow. One solution is to configure the app to use a different channel (change it from 1 to 2). Then, you will have to edit the routing in Midiflow so that it not only filters the note range, but also remaps the channel from 1 to 2. See https://www.midiflow.com/documentation/ ... -remapping for more info.

Other synth apps have a more sophisticated MIDI settings page and allow you to specify the input MIDI ports, and not only the channel. In that case, you might be able to disable your Keyboard there.

I hope that helps!
Johannes

Post Reply