CC not mapping correctly

Need help with Midiflow? Ask here!
Post Reply
richmois
Posts: 2
Joined: Sat Jan 11, 2020 8:58 pm

CC not mapping correctly

Post by richmois » Sat Jan 11, 2020 9:06 pm

I'm using the following harware:

Headrush Looperboard
iRig Blueboard (bluetooth)
BM-A01 (midi bluetooth)

I'm trying to control my looper , using Blueboard and BM-A01 being plugged to the looper.
It is difficult to configure, and I have only been successfull in mapping the Blueboard switch A (cc20) to the looper "start/stop all" button.

When I try to map other Blueboard buttons , Midiflow seems to send the same cc messages to the BM-A01, even if the set-up is different.

I attached screen captures showing that CC20 is correctly mapped to CC000, but CC21 is mapped to CC000 instead of CC012 as it should.

Can you help me?
Attachments
CC21.JPG
CC21.JPG (20.41 KiB) Viewed 96 times
CC20.JPG
CC20.JPG (17.92 KiB) Viewed 96 times
Last edited by richmois on Fri Jan 17, 2020 3:20 am, edited 1 time in total.

User avatar
Johannes
Site Admin
Posts: 125
Joined: Mon Mar 25, 2019 3:06 pm

Re: CC not mapping correctly

Post by Johannes » Sun Jan 12, 2020 9:49 am

Hi
Please select "MSB" (instead of "MSB+LSB") for the outgoing controller.

Best,
Johannes

richmois
Posts: 2
Joined: Sat Jan 11, 2020 8:58 pm

Re: CC not mapping correctly

Post by richmois » Sun Jan 12, 2020 8:31 pm

Hi,

When I select MSB, and CC12 mapped to CC21, the resulting CC are 000 and 127, instead of CC12.

If MSB+LSB is not selected, with CC3, then the Looperboard has no reaction to CC messages.

The lopperboard manual shows:
MIDI Control: Footswitch Actions (CC#3)
All actions on this page are triggered by sending the listed Data Messages using MIDI CC#3
messages. (See attachment)

Thanks

Richard
Attachments
CC#3 HeadrushJPG.JPG
CC#3 HeadrushJPG.JPG (94.26 KiB) Viewed 91 times

Post Reply